Software Resources‎ > ‎MacQIIME‎ > ‎

Add fastq-join to MacQIIME 1.8.0

Thursday, January 16th, 2014

Sorry, I overlooked including some of the dependencies for joining Illumina paired-end reads with join_paired_ends.py.  You need to have either ea-tools or SeqPrep installed for this QIIME script to work.  Here is a package that will install both of these into your /macqiime/bin/ folder for you.  Just follow these instructions:

1. Download the Add_ea-tools_to_MacQIIME-1.8.0.tgz file from here.

2. Open the Terminal, and, assuming that download in step 1 went into your Downloads folder, navigate there with cd:

cd ~/Downloads/

3. Unzip the file and enter the newly created directory.

tar -xvf Add_ea-tools_to_MacQIIME-1.8.0.tgz
cd Add_ea-tools_to_MacQIIME-1.8.0/

4. Run the installation script included in that directory. It will just copy over the files in the bin directory to /macqiime/bin/. If you want to put them somewhere else instead, manually, by all means please feel free to do so. It'll work fine as long as they're in the PATH somewhere.

./install.script

Copying the files requires administrative privileges, because the destination is owned by root.  So, you will be asked for your administrative password.

Please let me know how it works, and if you have any questions; thanks! 

 -Jeff
ċ
Add_ea-tools_to_MacQIIME-1.8.0.tgz
(262k)
Jeff Werner,
Jan 16, 2014, 7:32 AM